RaspberryPi:ラズパイでpandasが使いたいけどimportできない

Raspberry Piでpip install pandasしてpandasを使おうとすると

importerror: missing required dependencies [‘numpy’]

こんなエラーが出てきました。numpyはすでにインストールしている状態でした。

この問題を解決するには、pip installしたnumpyやpandasをアンインストールして、aptでpython-pandasをインストールする必要があるようです。

[bash title=” ”]
pip uninstall numpy
pip uninstall pandas

pip3 uninstall numpy
pip3 uninstall pandas

sudo apt install python-pandas
[/bash]

参考
https://qiita.com/Avocado/items/ba800e5afffc2bd98dc6